Update your Brave browser, Gemini wallet is here!!

Update your Brave browser, Gemini wallet is here!!

Share:

Desktop users can update their browsers to version 1.29 to connect to the Gemini wallet. Though Android users will have to wait a bit longer for the release. The best part is there is no minimum BAT requirement for users to verify their wallets with Gemini.

Gemini Wallet

The future of BATs is promising. They’ve thought about the premium and ad-supported model for the Brave search, though right now it’s in Beta. You can check their FAQs in the link below and they also kinda discussed this in their AMA.

No minimum 15 BAT shenanigans. Enjoy your free BATs.

Gemini Wallet Release

Brave Search

submitted by /u/No_Locksmith4570
[link] [comments]